Cách cập nhật phiên bản PHP của bạn

Linh Dinh March 20, 2024 No Comments

PHP là ngôn ngữ kịch bản phía máy chủ phổ biến nhất, cung cấp sức mạnh cho hàng triệu trang web bao gồm hầu hết các cửa hàng WooCommerce.

Nếu bạn đến trang này từ thông báo trong cửa hàng WooCommerce của bạn, cửa hàng của bạn đang chạy outdated and unmaintained phiên bản của PHP. Hiệu suất của trang web của bạn thấp hơn (nhiều) so với mức cần thiết, bạn có thể thấy mọi thứ không hoạt động như bạn mong đợi và đang mở cửa cho các lỗ hổng bảo mật!

PHP là gì?

PHP là một ngôn ngữ kịch bản có khả năng cung cấp sức mạnh cho webshop WooCommerce của bạn. PHP, giống như tất cả các phần mềm khác, được cập nhật theo thời gian để vá lỗi bảo mật và cải thiện tính năng của nó. Và giống như phần mềm khác, quan trọng là cần cập nhật phiên bản PHP của bạn.

Cập nhật phiên bản PHP của bạn

Liên hệ với nhà cung cấp dịch vụ lưu trữ của bạn

Trong hầu hết các trường hợp, bạn không thể tự cập nhật phiên bản PHP mà cần liên hệ với nhà cung cấp dịch vụ lưu trữ của mình về điều này. Quá trình nâng cấp là một quá trình dễ dàng và nên là điều nhà cung cấp dịch vụ lưu trữ của bạn có thể thực hiện cho bạn mà không ảnh hưởng đến trang web của bạn hoặc tính phí. Dưới đây là một thư bạn có thể gửi cho công ty lưu trữ của bạn:

Kính gửi nhà cung cấp dịch vụ lưu trữ,

Tôi đang vận hành một cửa hàng WooCommerce trên một trong những máy chủ của bạn và WooCommerce đã khuyến nghị sử dụng ít nhất PHP 7.0. WordPress, hệ thống quản lý nội dung mà WooCommerce sử dụng, đã liệt kê PHP 7.4 là phiên bản được khuyến nghị trên trang yêu cầu của họ: https://wordpress.org/about/requirements/

Bạn có thể vui lòng cho tôi biết nếu dịch vụ lưu trữ của tôi hỗ trợ PHP 7.0 hoặc cao hơn và làm cách nào tôi có thể nâng cấp?

Rất mong nhận được hồi âm của bạn.

Máy chủ VPS

Nếu bạn có máy chủ VPS, xem Cách nâng cấp từ PHP 5 .

Nhà cung cấp dịch vụ lưu trữ của tôi không hỗ trợ PHP 7.0

Nếu nhà cung cấp dịch vụ lưu trữ của bạn không hỗ trợ PHP 7.0 hoặc cao hơn, chúng tôi khuyến nghị bạn tìm một nhà cung cấp dịch vụ lưu trữ có hỗ trợ. Chúng tôi có danh sách các giải pháp lưu trữ WordPress chúng tôi khuyến nghị và tất cả đều hỗ trợ PHP 7.0 hoặc cao hơn. Nếu bạn liên hệ với nhà cung cấp dịch vụ lưu trữ khác, hãy chắc chắn hỏi họ phiên bản PHP nào trang web của bạn sẽ chạy trước khi mua.

Thêm thông tin

PHP có danh sách phiên bản không được hỗ trợ bao gồm các ngày trên trang web của họ . Nếu bạn tự phát triển các plugin WordPress, bạn có thể muốn xem thư viện PHP có tên WPupdatePHP .

Leave a Reply

Your email address will not be published.